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Introduction 
 

The Canems ECU has been designed to replace distributor based ignition systems, hence 
the term distributorless ignition. By doing away with the king lead, rotor arm and 
distributor cap, the maximum possible voltage is applied to the spark plug tip where it is 

required. Wasted spark ignition coils are also able to charge very quickly ensuring that a 
strong spark is present even at very high RPM figures. 
 
In other applications, we are able to retain the distributor for classic appearance or 
functional reasons, but use the ECU to control the ignition advance curve and/or provide a 
programmable rev-limit. 
 

Along with the obvious advantages of providing a much stronger spark, the Canems ECU is 
fully programmable. This means the ignition advance curve can be tailored to suit your 
own vehicle regardless of modifications. Traditionally, this would be a labour intensive 
procedure where the distributor advance curve would need to be mechanically modified. At 

best, the resultant advance curve would be a compromise due to the limited adjustability 
available within the distributor. 
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Specifications 
 

· 3D programmable ignition based on engine load and engine speed 

· Fully adjustable timing including boost retard, mappable on-the-fly 
· Constant energy ignition maintains spark efficiency at high RPM 
· Adjustable dwell time configuration 
· COP (coil-on-plug) support 
· Engine speeds up to 12000 rpm 
· Compatible with 36-1, 60-2, Renault/Volvo Renix 44-2-2, Rover 36-2 (early K-

   series  and T-series), Rover 36-4 mode A & B (K-series) and Suzuki 24-2 triggers. 

· No specific positioning is required between crank sensor and trigger wheel  
· Sequential gearbox shift support 
· Programmable and dynamic launch control 

· Switchable maps on-the-fly 
· High/low rev limiter option (valet mode) 
· Data logging facility 

· Serial port connection to PC with optional USB support 
· Supplied with Windows compatible tuning software and connection cable 
· Programmable shift light output 
· Programmable hard and soft rev limiters 
· Choice of load sensor - either MAP or TPS 
· Compatible with one, two or three Bar MAP sensors 
· Automatic dwell time compensation 

· Password control for engine builders / locked racing series 
· Suitable for four cylinder engines 
· 12V negative earth voltage supply 
· Rugged anodized aluminium outer casing with mounting lugs 

· Compact unit:  126mm x 63.5mm x 29.5mm 
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Using the software 
 

To install the software, insert the CD into your CD-ROM drive. The software installation 
process should begin automatically. If this is not the case, click on the ‘My Computer’ icon 
on your desktop and right-click the CD-ROM drive. Now click ‘Browse’. 

 

Double-click the icon named ‘Setup’, and this will start the installation process. 

 

A message will appear once the installation has completed successfully. This means you 
can start the Canems Injection Tuner software either by double clicking on the Canems 

icon on your desktop or by accessing the Start > Programs menu. 
 

 

Connecting the ECU 
 
Once the ECU is installed in your vehicle with an ignition-switched power supply, you can 
test the communication between the tuning software and the ECU module. 
 
The first step in this procedure is to connect the supplied communication lead between the 

ECU and your personal computer. The communication lead has a female connection at one 
end and male at the other. Therefore, it is not possible to connect the two items 
incorrectly. 
 
On your computer, the communication lead plugs into a spare serial / COM port. Most 
computers have such a connection. If your computer does not, USB adaptors are available 

from Canems. Do not attempt to use a USB adaptor from another supplier, as they can 

disrupt communication with the ECU. 
 
Once the communication lead has been attached, you can start the Canems Ignition Tuner 
software. This will display the default screen:  
 

 
 

When the vehicle ignition is turned on, the Canems software will automatically detect your 
ECU. The connection status message will change from ‘ECU not detected’ to ‘Connected 
successfully’. 

 

Once the software has managed to locate the ECU, all settings will be downloaded to your 

computer. This process is instantaneous, and is the starting point from where you can 
begin to modify the ECU settings – referred to as ‘mapping’. 
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Inputs, outputs and real-time data 
 

Under the ‘View’ menu, you will find an option to display ‘Mapping Essentials’ for the 
ECU. As a default, the Canems software shows the main dashboard, though this can also 
be displayed by clicking ‘Dashboard’. 

 

The Mapping Essentials screen (‘View > Mapping essentials’) is designed to show the 
most important data, so it is recommended to load this window when mapping is in 
progress. 

 

 
 

 

Loading and saving files 

 

It is a wise precaution to save your ECU settings onto your computer. This is particularly 
true during the mapping process, where it is very easy to upset the engine tuning and 
therefore you may need to reload your previous settings. To save the ECU settings, click 
‘File > Save calibration’.  

 

When loading a calibration file, the engine should not be running. The ECU must of course 
be connected to the host computer and have a voltage supply (ie. status LED is red). To 
load a calibration file, click ‘File > Load calibration’. 

 

It is recommended that a backup copy is frequently saved during the mapping process. 
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Firmware Files 
 

When major changes need to be made to your ECU, you’ll need to change the software 
inside the ECU itself. One example would be swapping from a 36-1 to a 60-2 trigger wheel. 

 

To get the latest firmware files, visit the Canems website. From here, upgrades for your 
ECU can be downloaded free of charge. Firmware files are also distributed with your 
installation CD though naturally they may not be the most recent. 

 

Uploading firmware files 
 

Changing the firmware in the ECU is a simple process. It is recommended to backup your 
settings before uploading firmware, although they are not overwritten during the upload 
process. With the ignition off, connect the tuning lead to your computer and open the 

Canems Firmware upload software. This will be in your ‘Start > Programs > Canems’ 
folder. 

 

 

 

Now, select ‘Open file’. Choose which firmware version you’d like to use by clicking 
‘Open’. (This screen shown below left) 

 

  

 

To begin the upload process, simply choose the COM port to which the ECU is connected 
(the Canems software will tell you which ports are currently active) and then click ‘Start 

Update’. Now turn on the ignition. The firmware upload takes approximately fifteen 
seconds, after which the ECU is ready to use. (Shown above right). 

 

Note that the status LED will turn off during a firmware upload. As soon as the upload 
completes, the LED will return to normal (red, indicating that power supply is present). 
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Speed sensing 
 
The Canems Ignition ECU usually measures engine speed with the use of a toothed wheel. 

Ferrous teeth on the outside edge of this trigger wheel rotate past a crank sensor. By 
analysing the signal from this sensor, the ECU is able to calculate engine speed. The name 
’36-1’ implies that there are thirty five teeth and a gap. Similarly ‘60-2’ implies fifty eight 
teeth and a gap. The gap is used to locate top-dead-centre (TDC) of number one cylinder.   
 
If your engine is not already fitted with a compatible trigger wheel, suitable laser-cut items 
are available from Canems. Aftermarket trigger wheels should be mounted to the 

crankshaft, typically behind the bottom pulley. 
 
Alternatively, it is also possible to convert your existing pulley into a trigger wheel with 

machine work. This is possible with harmonic balance pulleys that have plenty of material 
on their outer face that can be machined. The width of each tooth should be kept 
approximately equal to the width of each gap. We can modify such pulleys on an exchange 

basis. 

 
 

Typical laser-cut trigger wheel 

 
The Canems ECU is supplied with the static timing set at 90 degrees. This implies that the 
missing tooth is 90 degrees ahead of the crank sensor in the direction of crankshaft 
rotation; compatible with most Ford engines. The default timing position is shown in the 
screen-shot below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Default timing figure in Canems ECU – see ‘Software Help’ for more details 
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Depending on your abilities, there are two ways to set the static timing:  
 
Mechanical method: 
Turn the engine to TDC for number one cylinder (does not need to be on firing stroke). 

Fabricate crank sensor mounting bracket and install crank sensor such that it is facing the 
crankshaft pulley. Mark the point on the crankshaft pulley which is opposite the centre of 
the sensor. Carefully measure 90 degrees from this point, in the direction of crankshaft 
rotation. This is where the centre of the missing tooth should be located. 
 
Software method: 
Install trigger wheel and crank sensor wherever convenient. Turn the engine to TDC for 

number one cylinder (does not need to be on firing stroke). Now measure the angle from 
the centre of the crank sensor to the centre of the missing tooth, in the direction of 
crankshaft rotation. This angle is the ‘static timing’ angle, and must be programmed into 

the ECU. For example, if the angle was 283 degrees: 
 

 
 
In the static timing box (ECU Setup > Static timing), type the angle. In this case, 283 
degrees. Then click Save settings. The on-screen trigger wheel will rotate to mimic the 
positions of the trigger wheel and crank sensor on your own engine. Double check that the 
on-screen simulation matches the layout on your own engine. 

 
In practice, even with careful measurement, the true timing position can be a few degrees 
out from this theoretical figure. It is therefore recommended to verify the timing with a 
strobe light once the engine is running. The static timing can then be trimmed to the 
nearest one degree, using the software method described above. 
 
Note that strobe lights can interfere with the ECU power supply. Therefore, always use an 

external power supply for the timing light. Furthermore, because the ECU uses a wasted 
spark ignition system, some advanced strobe lights can be fooled into thinking the engine 
is running at double speed. If in doubt, either use a basic strobe light with no 
advance/retard knob or else set the advance/retard knob to zero degrees. 
 
Example: 
 

A Mini owner needs to verify the static timing figure. By measuring the angle from the 
crank sensor to the missing tooth, the owner has already set the static timing at 283 
degrees. The engine has started and is running with this static timing figure, so he knows 
the timing isn’t far out. He has read that he needs approximately 15 degrees of ignition 
advance at 1500 rpm. Thus, he locks the ignition timing figure and then clicks Save 
settings: 
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The owner now holds the engine at approximately 1500 rpm, and attaches the strobe light 
inductive pickup to number one HT lead. Most Minis have a series of pointers protruding 
from the timing case. The top-most pointer indicates TDC. Each subsequent pointer 
indicates 4 degrees of ignition advance. 

 
With the strobe light 
running, the TDC marker 
coincides with the second 
pointer on the timing case 
(left).  
 

So the engine is actually 
running with eight 
degrees of ignition 

advance. The static timing 
figure needs to be 
advanced by seven 

degrees to give the 
desired timing figure of 
fifteen degrees. The static 
timing is adjusted in 
software, and the timing 
checked again (right). 
 

 
 
The crank sensor should be a VR (variable reluctance) type sensor. These create an A.C. 
voltage signal which corresponds to the teeth on the trigger wheel rotating past the tip of 

the sensor. Some common VR sensors: 
 

 

Sensor 

 

Connections 
 

Ford 

 

1. Crank sensor signal (ECU pin 14) 

2. Crank sensor earth (ECU pin 13) 
 

Vauxhall 

 

1. Crank sensor signal (ECU pin 14) 

2. Crank sensor earth (ECU pin 13) 

3. Cable shielding (ECU pin 12) 
 

Peugeot 

 

1. Crank sensor signal (ECU pin 14) 

2. Crank sensor earth (ECU pin 13) 

3. Cable shielding (ECU pin 12) 
 

Magneti Marelli 

 

1. Crank sensor earth (ECU pin 13) 

2. Crank sensor signal (ECU pin 14) 

 
 
The crank sensor we supply is a Ford item with connections as described above. They use 
a Junior Timer connector to plug into the wiring loom – again, these are also used on the 
majority of temperature sensors and fuel injectors. 
 

It is important to note that VR sensors are polarity conscious. The connections for Ford and 
Vauxhall sensors are noted in the table above, but for different sensors you must 
determine which connector is positive and which is negative. The sensor should produce a 
positive voltage when brought towards a steel object, and a negative voltage when taken 
away again. This can be verified with a multi-meter. 
 
The crank sensor should be mounted on a very rigid support so that the sensor is aiming 

towards the centre of the crank pulley. Ensure that the bracket will not work loose or 
fatigue over time, as the ECU cannot function without an RPM reading. Also take special 
care to ensure that the crank sensor mounting will not vibrate in use. Insubstantial 
mountings tend to produce a consistent, harsh misfire at a fixed engine speed. 
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When installed, the tip of the crank sensor is typically mounted 1 to 2 mm away from the 
trigger wheel teeth. If the sensor is any further away than this, the signals from the sensor 
may become unreliable when starting the vehicle. Ensure that the crank sensor mounting 
will move in unison with the engine and is not attached to the body shell of the vehicle. 

 

 
 

One example of a custom application; a Subaru Impreza boxer engine. In this case, a laser cut 36-1 
toothed wheel mounted behind the original pulley and retaining original crank sensor. 

 
The connection between the crank sensor and the ECU is vitally important for the function 
of the engine and therefore our wiring looms incorporate special shielded cable. The 
shielding helps to isolate the crank sensor signals from electrical interference. The braiding 

of the cable is connected to earth at the ECU end only, and this forms a protective barrier 
around the positive and negative signal wires. If you are building your own wiring loom, 

make sure you use shielded cable for the crank sensor signal. Contact us for supply. 

 

 
 
 

Typical shielded cable, with outer braiding hidden under PVC outer / heat shrink wrap 
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Load sensing 
 

The main ignition map in the Canems ECU is three-dimensional. This means the map has a 
speed-referenced axis and a load-referenced axis. The speed axis is based on how quickly 

the engine is turning, while the load axis is based on how hard the engine is working. For 
example, an engine pulling top gear up a hill is working much harder than an engine 
coasting downhill in second gear. This is where the load sensor comes in – it can 
differentiate between the two conditions. 
 

Whenever possible, it’s recommended to use a MAP (Manifold Absolute Pressure) sensor to 
detect load. These devices connect to the inlet manifold via vacuum piping and report the 

current manifold pressure to the ECU. The Canems ECU can use one, two or three Bar MAP 
sensors so it is capable of controlling forced induction applications. For normally aspirated 

applications with high lift / overlap camshafts or ITB's (individual throttle bodies), it is also 
possible to use a throttle position sensor (TPS) to measure engine load. This avoids the 
problem of a fluctuating vacuum signal which a MAP sensor would find hard to measure 
accurately. TPS devices do not measure true engine load, but base their load prediction 
around the current throttle position. For race applications, this solution can be 

advantageous. 
 

MAP sensors 
 

The Canems ECU is compatible with 0 – 5V analogue sensors. The MAP sensor we supply 
by default is a GM item. A short section of vacuum piping will be required to connect the 
MAP sensor to the take-off point of the inlet manifold on your engine. The MAP sensor 
should be connected to a common vacuum point, such as the servo take-off. The sensor 
should see high vacuum under light load and low vacuum under heavy load. 

 

 
 

MAP sensor installed in TVR, with vacuum pipe connected to inlet manifold take-off 

 
The GM MAP sensors supplied by Canems have three connections. These are marked A, B 
and C on the sensor casing itself, as shown in the picture below. Connection A is an earth, 
B is the output signal and C is a reference voltage. 

 

C   B   A 

 

 

 

 

 

 

 

 
 

GM MAP sensor showing vacuum port and three connections 
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Throttle position sensors 
 

The Canems ECU is compatible with all three-wire throttle position sensors. One 
connection is an earth, another is a 5V supply and the third wire is the output signal. 
Connections for the Canems-supplied TPS are listed below: 

 
 

Sensor 

 

Connections 
 

Canems 

 

1. 5V supply (ECU pin 3) 

2. TPS signal (ECU pin 4) 

3. Earth (ECU pin 11) 

 
For other makes of TPS, it’s also possible to determine the connection layout with a 

multimeter. First, connect an ohm-meter across two wires of the TPS. If the resistance 
reading does not change as you rotate the TPS spindle, then the wire that is not connected 
to the ohm-meter is your signal wire. Note that the signal wire is nearly always the middle 
wire out of the three, which makes it easy to find. 

 
Now connect the ohm-meter to the signal wire and one of the other two wires. Gradually 
open the throttle and note down whether the resistance is increasing or decreasing. If the 
resistance is increasing, then the disconnected wire is the 5V supply. If not, the 
disconnected wire is the earth. 
 
Physically, the TPS should be installed so that it follows the movement of the throttle 

butterfly / butterflies. It is therefore usual to attach a TPS to the end of the throttle spindle 
or perhaps combined with a bell crank mechanism that the throttle cable traverses. 

 

Setting the ECU 
 
After fitting a load sensor, you must tell the ECU which type you are using. To do this, click 
‘ECU setup > Basic setup’. 
 
 

 
 

 

Select whether the ECU is to use a MAP sensor or TPS to measure load . Also specify which 
type of MAP sensor is connected (if applicable). Having made changes, be sure to click 
‘Save settings’. 

 



Canems Ignition ECU              www.canems.co.uk                Release Version 2.14 

If a throttle position sensor has been fitted, be sure to calibrate the sensor before going 
any further. To do this, click ‘ECU setup > Calibrate TPS’. For more information, see 
‘Calibrating the TPS’. 

 

Having specified which type of load sensor the ECU should use, you should check that the 
load sites are set to sensible values and sensibly spaced. All 3D maps refer to the load 
sites, as they form the vertical axis of the map. To set up the load sites, click ‘Ignition 
map > 3D ignition map’. 

 

 

 

There are fourteen load sites in the Canems ECU, and these should be programmed to fall 

within the range of possible load values. Load values should increase in size from bottom 
to top.  

 

When using a MAP sensor, load is measured in kilopascals (kPa). A one bar sensor ranges 
from 0 - 100kPa (0kPa being minimum load). Two bar sensors range from 0 - 200kPa and 

three bar sensors from 0 – 300 kPa. TPS load values range from 0 to 100%, with 100% 
denoting full throttle and therefore full engine load.  

 

After changing load site values, click ‘Save settings’. 

 

 

2D mode 
 
It's perfectly feasible to run an engine based on engine speed alone (no MAP sensor or 
TPS). This is typical for circuit racing applications when the engine is either at full load or 
turned off.  

 

To select 2D mode, click 'ECU setup > Basic setup'. From this menu, you can opt to use 
2D maps. When this feature is selected, the ECU will operate from the low load sites only 
in the 3D map (ie. the bottom eighteen speed sites). 
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Ignition 
 
The Canems ECU supports distributorless, wasted-spark ignition for four cylinder engines. 
This provides constant-energy ignition throughout the rev range. The ECU can virtually all 
coil types available, the most commonly used are the Sagem/Valeo unit or the Ford unit. 

 

         
 

Common wasted-spark coils; Sagem/Valeo (Left) and Ford (Right) 

 

After fitting a wasted spark coil, it is important to set the dwell characteristics in the ECU. 
To do this, click ‘Ignition > Dwell setup’ 
 

 

 

Most typically, the dwell time will be in the region of 3.8 to 4.0ms with the voltage 
correction table left at our default setting. Coil on plug installations or single coil & 
distributor installations can vary dramatically however, so please contact Canems if this is 
the case with your engine. Remember to click ‘Save Settings’ after any changes have 
been made. 

 

Coil-pack connections 
 

 

Coil 

 

Connections 
 

Ford or Vauxhall three pin 

 

1. Ignition switch - cylinders 1 & 4 (ECU pin 1) 

2. 12v supply 

3. Ignition switch - cylinders 2 & 3 (ECU pin 7) 
 

Sagem / Valeo 

Or Vauxhall four pin 

 

1. Ignition switch - cylinders 1 & 4 (ECU pin 1) 

2. Ignition switch - cylinders 2 & 3 (ECU pin 7) 

3. 12v supply 

4. Not connected 
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Ignition maps 
 

To program an ignition advance site, click the value you wish to modify. Then replace with 
the new advance value and press enter. This will send the value to the ECU, which will 

start to use the new settings immediately. The status bar in the tuning software will show 
‘Calibration changed’. This denotes that the ECU settings have been modified but not 
saved. To store the settings permanently, you must click ‘Save settings’. 

 

You can also use the arrow keys, PageUp / PageDown keys and Enter to navigate the map, 
modify values and send them to the ECU, respectively. 

 

 

 

To view a 3D representation of the ignition map, click ‘View 3D graph’ from the Spark 
Map screen itself. This will launch a new window with the 3D view. The 3D view can be 
useful for smoothing peaks and troughs in the advance curve and ensuring that the map 
follows a general pattern. 

 

 

When programming the 
maps, it can be useful to 
have a visual indicator as to 
where the ECU is currently 

operating. To view such an 
indicator, click on ‘Trace 

ECU’ either on the map itself 
or the 3D representation. 
This will display a black 
marker which points to the 
current position / value in the 
map. This is very helpful 
when mapping the system. 

 

 

 

Irrespective of whether the engine is running with wasted spark ignition or not, resistor-

type spark plugs should always be used. For example, NGK part number BP6ES would be 
replaced with BPR6ES. If in doubt, check, because using non-resistor plugs can produce 
sufficient electrical noise to interfere with the ECU operation. Spark plugs should be 
gapped to 0.030” – 0.040” for normally aspirated applications. 
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Rev limiters 

 

The Canems ECU features two programmable rev limiters. The first-stage limiter is known 
as a ‘soft’ limit. When this activates, the ignition timing is retarded to 10º before top-dead-
centre. This should produce a noticeable drop in engine performance and may well prevent 
the engine from reaching higher speeds. Combined with the shift light output, this should 
be enough to indicate that a gear change is required. 

 

As a safety-net, there is also a programmable ‘hard’ rev limit. Typically, this will be set 
about 200 RPM above the soft rev limit value. The hard rev limit represents the true 
maximum engine speed. When the hard rev limit is reached, all ignition outputs will be 
prevented. 

 

 

 

The hard rev limit can be set at different speeds for primary and secondary maps. 
Commonly this will be used a wet/dry map for competition vehicles, or a 'valet mode' for 
prestige applications. 

 

To set the rev limiters, click ‘Ignition > Rev limiters’. Select whether the soft rev limit 

and / or hard rev limits are enabled, and specify their activating RPM. Click ‘Save 
settings’ to store the changes in the ECU. 
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Tachometer output(s) 
 

When running wasted spark ignition, there are two coils, each of which fire half as 
frequently as a traditional single coil. Therefore, the tachometer cannot take an input from 
a single negative (CB) coil terminal, as it would register half RPM. 

 

To solve this problem, the Canems ECU features an inbuilt tachometer output, which 
mimics the behaviour that a traditional tachometer expects to receive. Simply connect ECU 
pin six to the tachometer sense wire. 

 

Some older vehicles are fitted with inductive-type tachometers (eg. Smiths RVI). In this 
case, the wasted spark coil pack should receive its voltage supply from the original coil 

supply wire. This wire runs in series with the inductive tachometer, which detects the 
pulses of current which are drawn every time an ignition coil is charged and fired. 

 

 

 

   

 

 

 

 

 

 

 

On more modern installations (typically where the original vehicle was running with EFI), 
the tachometer may expect a 12v digital square wave signal, rather than the high voltage 
'kick' produced at ECU pin six.  

 

In this case, you can assign ECU Output 2 (pin 15) to act as a tachometer output. This will 
provide the 12V square wave RPM signal that most modern tachometers expect. 

 

 
 

One of the three methods above will run the tachometer successfully in ninety-nine 
percent of applications, but in some rare circumstances you may still struggle to run your 
tacho accurately. In such cases, Canems do offer a tacho driver module that can be 

installed inline, between the ECU and the gauge itself. Contact us for more details of this 
universal product. 
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RPM outputs (shift light, VTEC etc.) 
 

The RPM outputs provide an RPM triggered switch. They are capable of sinking 800mA 
current which is enough to drive all LEDs and most low-powered warning lamps. 
Remember that the output provides a switched earth, so the shift light will be connected to 
a 12V ignition-switched supply and the ECU output pin. 

 

To program the shift light, click ‘Inputs/Outputs > Output X’. 

 

 
 

RPM outputs are available on both Output 1 (ECU pin 5) and Output 2 (ECU pin 15). 

 

To enable the RPM output, click ‘RPM switch enabled’. The activating engine speed can 
then be programmed to the nearest 50 RPM. After changing the settings, be sure to click 
‘Save settings’. 

 

 

Switchable maps 
 

You can use the programmable input pin (ECU pin 10) to control primary and secondary 

ignition maps. Select 'ECU Setup > Basic setup', and then select 'Switchable maps' as 
the function for ECU pin 10.  

 

 

This pin is an active-low input, 
meaning that you will connect to 
earth to enable the secondary 
maps. 

 

The secondary ignition map is 
found under the menu 'Ignition 
> Secondary ignition map'. 

 

To copy your existing data from 
primary to secondary maps 
(much easier than typing by 

hand!), click 'ECU setup > Copy 
maps (pri. to sec.)'. 
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Sequential gear cut 
 

The ignition ECU can communicate with a sequential gearbox via pin 10. Secondary 
ignition maps / launch control will be disabled in this case. Select 'ECU Setup > Basic 
setup', and then select 'Sequential gear cut' as the function for ECU pin 10.  

 

This pin is an active-low input, meaning that a negative (earth) signal on pin 10 will 
activate the sequential gear cut. 

 

 

To access the gear change settings, 
click 'Inputs/Outputs > 

Sequential gear gut' (illustrated 
above). Setting the change time to 
zero will kill the spark output as long 
as the pin is held to earth.  

 

 

 

 

Setting the change time higher than zero will introduce a timed element to the gear cut; a 
typical setting would be 0.050 seconds (50ms) to start with. It is worth noting that the 
earth signal from the gearbox control module must be shorter than the gear change time 

in the Canems ECU, otherwise it will act to kill the spark output as long as the pin is held 
to earth. 

 

Launch control 
 

General purpose input pin 10 can also be used as a launch control trigger. Select 

'ECU Setup > Basic setup', and then select 'Launch control' as the function for ECU pin 

10. Connect a push button or rocker switch (depending on your trigger preference) 
between this pin and earth.  

 

To access the launch settings, click 'Inputs 

/ Outputs > Launch control' (illustrated 
right). 

 

You can either program a full-time launch 
RPM (4000rpm, for example) that the ECU 

will remember, or if you set the launch RPM 
to zero this will enable the dynamic launch 
speed. 

 

Simply rev the engine to your desired 
launch RPM and then press the putton. This 
will temporarily lock the launch speed until 
launch mode is disengaged. 

By default, the launch control is set up to use a 'toggle' switch mode. That is, the launch 
control is enabled when ECU pin 10 is connected to earth. It is not disabled again until the 
switch is pressed. Use a push button push-to-make switch for this mode. 

 

You also have the option of running a rocker switch (a standard on/off rocker). If you want 
to do this, make sure to select 'Activate launch while switch is earthed'. As the name 
implies, the launch control will be active whilst the switch is connected to earth and 
deactivates when the switch is open. 
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ECU password control 
 

It can be preferable to deny access to the ECU settings in certain circumstances (engine 
builders requiring a specific RPM limit / locked racing series etc.) If this is the case, a six 
digit alphanumeric password can be programmed into the ECU as follows: 

 

 

Click 'ECU setup > Password control' 

 

Click to enable the password control and enter a 
password of your choosing. Make sure you keep this 
written down in a safe place! 

  
ECUs can be unlocked by Canems in the worst case 
scenario. 

 

 

 

Cranking oscilloscope 
 

We find that any installation problems are usually caused by a bad crank sensor 
installation, whether that be down to wiring, the physical trigger wheel setup or the sensor 
itself. 

 

You can therefore use the software oscilloscope (below) to analyse the trigger pattern that 
the ECU is receiving from the crank sensor. 

 

  
 

Click 'Diagnostics > Crank sensor check' and you will see a blank screen. Turn the 

engine over for few rotations but leave the vehicle ignition turned on. Now click 'Fetch' to 
grab the crank sensor data from the ECU itself.  

 

Individual tooth times accurate to one millionth of a second are displayed on the left hand 

side of the screen, with a visual representation of this information also produced. Naturally 

this data should mimic the pattern on your trigger wheel itself - in the case of the example 
shown above, this is a 36-1 Ford pattern trigger wheel running at around 2000rpm. 
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Transient advance 
 

Transient advance limiting attempts to replicate the mechanical nature of a conventional 
ignition system by limiting the rate of change in ignition advance. For example, it will not 
allow a change from 0˚ BTDC to 40˚ BTDC in one single crankshaft stroke. 

 

You are able to specify the rate of change for both ignition advance and retard, with 
respect to engine speed. 

  

 
 

To modify these settings, click 'Ignition > Trasient advance'. 

 

When set correctly (usually done when all steady-state mapping has been completed), you 
should notice a slightly smoother engine response during heavy transient conditions (ie. 
fast throttle on/off/on).  

 

Naturally, ignition advance limits should not be set so low as to affect the response of the 
engine. 
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Data logging 
 

The Canems Ignition Tuner software has inbuilt data logging capabilities, so that real-time 
parameters can be saved to the connected computer and played back at a later time in 
graphical form.  

 

To start a data logging session, click ‘Logging > Start’. You will be prompted for a file 
name, under which the data log will be saved. Clicking ‘Ok’ will commence the log, and the 
chosen parameters will be saved successively to the connected computer. The status bar 
will indicate ‘Datalogging’ to show that the logging process has begun. Similarly, to stop a 
data log session, click ‘Logging > Stop’. The status bar will indicate ‘Not data logging’. 

 

To view a saved data log, click ‘Logging > Log viewer’.  

 

 
 

After opening the Log Viewer, click ‘Open data log’ and select the data log file that you 

wish to view. By default, the Log Viewer shows the first minute of the data log. If the data 
log is longer than this, the view can be moved forwards by either thirty seconds or five 
minutes by clicking ‘Forward 30s’ or ‘Forward 5min’, respectively. Similarly, the data log 
view is moved backwards in time by clicking either ‘Back 30s’ or ‘Back 5min’. 

 

The level of detail in the viewer can also be controlled, so that it is possible to ‘zoom in’ on 
an area of particular interest. To do this, click ‘Zoom in’ successively. Clicking ‘zoom out’ 
naturally has the opposite effect. 

 

Data Exports 
 

As with all Canems ECU systems, you can export our datalog files into a CSV file for 
further analysis using spreadsheet/graphing tools such as Microsoft Excel. Simply click 
'Logging > Export to CSV' and select the file name you'd like to convert. 

 

Choose a new file name for the exported CSV file and click 'Save' to store the file on your 
PC for future use. 
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WIRING 

 
The Canems ECU is provided with a ready made, colour-coded wiring loom. This is 
designed to make installation as simple as possible. 

 

 
Wiring loom and connector, as supplied with your Canems ECU 

 
Despite the versatility of the Canems ECU, only nine connections are absolutely necessary 
to get up and running: 
 

ECU earth and power 
2 x coil earths 
2 x coil triggers 
Crank sensor shield, return and signal 
 
The best way to connect your wiring loom is to position all of the components in the engine 
bay. Next, decide where the ECU itself will be mounted. The ECU should always be 

mounted inside the passenger compartment so that it is kept away from water and dirt. 
When everything is in position, plug the connection on the loom into rear of the ECU, and 
route the wires to your ignition components and sensors under the bonnet. The end of the 

loom will need to pass through a suitable rubber grommet or access hole in the bulkhead 
of the vehicle. 
 

When building the wiring loom, use heat-shrink tubing to insulate any connections. Also 
ensure that all of the wiring is protected from chafing, through the use of plastic conduit 
and rubber grommets wherever necessary. The wiring loom is an important part of the 
system; with inadequate wiring the Canems ECU may be unable to operate correctly. With 
a well made loom, the ECU will provide reliable service. 
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MAP sensor installation 
 

 
 

TPS installation 
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Wiring considerations 
 
It is recommended to use soldered joints throughout the wiring loom unless you have the 
correct crimping tools available. This will prevent intermittent wiring faults which could 
prove difficult to diagnose. Ensure that the wiring on a connector is not under strain, and 
never allow an unsupported section of wiring loom to be carried by a connector - instead 

support the loom wherever possible using cable (zip) ties. 
 
When installing the loom, ensure that there is enough wire to allow for flexing – no part of 
the loom should be under strain. Where the loom passes through bulkheads or other areas 
where chafing could occur, always use protective sleeving and rubber grommets. 
 
As mentioned in the ‘Speed sensing’ section, the crank sensor input must always be wired 

with shielded cable. Metal shielding, surrounding the signal wires, is earthed at the ECU 

itself. At the crank sensor end, simply unravel and remove unnecessary shielding. By 
connecting the shielding to earth at the ECU end only, a protective barrier is formed 
around the sensor signal which prevents electrical interference. Even so, the crank sensor 
wiring should be kept away from other wiring that is likely to promote interference – the 
HT leads and alternator should certainly be avoided. 
 

Perfect earth connections are essential to the operation of the ECU. The ECU earth 
connection (pin nine), and preferably all other earths, should be connected directly to the 
battery terminal where realistically possible. 

 
COP (coil on plug) applications 
 

It is becoming increasingly popular to use COP coil packs with engine swaps or 
conversions, and we have tried and tested software available to run these installations. 
 
You must power the coil packs via an ECU switched relay (normally connected to ECU pin 

5). The coil trigger wires (ECU pins 1 and 7) are used to fire the COP modules for cylinders 
1&4 and cylinders 2&3 respectively. 
 
Install a 100 Ohm pullup resistor between Pin 1 and the 5V reference (ECU pin 3) and 
another 100 Ohm resistor between Pin 7 and the 5V reference. This will provide a digital 
square-wave signal to the COP modules, as they are expecting. 
 

You must make absolutely sure that the COP modules are used only with the pullup 
resistors installed and the correct ECU firmware loaded. 
 

Similarly you must not try to use COP coils with standard 'DIS-type' firmware. 
 
One example project; VAG 036 905 715 E COP coils on a VW Polo/Bora engine. 

 
Coil pin: 
1. Earth 
2. Earth 
3. 12V supply from ECU switched relay 
4. Ignition trigger signal (white or brown wire from ECU, depending on cylinder). 
 

Dwell was set to 3.0ms with these specific coils. 
 
Please contact Canems if you are unsure about coil connections, wiring, dwell times or 
firmware applications. 
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Starting the engine 

 

Before attempting to start the engine, make sure you have read and understood all 
necessary sections of this installation guide. Remember that the basic engine design 
remains unchanged, even after fitting aftermarket management. Given the correct mixture 
of fuel, air and sparks, the engine will run.  

 

Calibrating the TPS (optional) 
 

There are several important checks / settings that should be made before attempting to 

start the engine. If the installation uses throttle position sensor (TPS) as the main load 
sensor, then it must be calibrated. This will allow the ECU to recognise full throttle and 

closed throttle, and anywhere in between. To load the calibration screen, click ‘ECU Setup 
> Calibrate TPS’. 

 

With the throttle fully closed, 
click ‘Get reading’ to find the 
closed reading. Similarly, fully 
open the throttle and record 
the open reading.  

 

The Throttle closed reading 
should be the lower of the 
two. If this is not the case, 

check your wiring to the TPS 

or alternatively click ‘Reverse 
TPS reading’. Which can be 
found under the 'Basic setup' 
menu.  

 

 

As with any changes to the ECU calibration, after reading the values, click ‘Save settings’ 
to permanently store this information in the ECU. 

 

Setting speed and load sites 
 

You must now choose suitable values for the ECU Speed Sites. These values form one axis 

in the 3D ignition map, and as such they help to determine ignition parameters for all 
engine speeds. To view the speed sites, click ‘ECU setup > Speed sites’. 

  

The speed sites should be spread across a suitable range from approximately 500 RPM up 
to the maximum expected engine speed.  It is common to group speed (and load) sites 

together more closely in some places, corresponding to the most frequently used engine 
speeds (or loads). This will allow a greater degree of fine-tuning in the most commonly 
used areas in a 3D map, ultimately leading to improvements in economy or performance – 
whichever is desirable. 

 

The load sites are set in a similar manner to the speed sites. Before setting the load sites, 
however, you must ensure that the correct load-sensing device has been specified (either 
MAP or TPS). For more information, see the section entitled ‘Load sensing’. 

 

Mapping mode 
 

The Canems ECU has inbuilt interpolation. This means that values from adjacent sites will 
always be taken into consideration when the ECU is locating a value. For example, 
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consider the case where the ignition timing is specified as 20º at 2000 RPM and 26º at 
3000 RPM. Using interpolation between the two values, the ECU will calculate that an 
advance figure of 23º is required at 2500 RPM. The effect of interpolation is to smooth the 
transition from site to site, blending values so that there are no sudden jumps in ignition 
timing.  

 

When you are setting-up the ECU (known as ‘mapping’) it can be advantageous to turn off 
the interpolation mechanism. Without interpolation, changes to a single site in a map will 

produce a much more obvious change in engine performance. Mapping with interpolation 
turned on would require all adjacent sites to be altered before a significant change can be 
recognised. 

 

To enable or disable interpolation, click ‘ECU setup > Basic setup’. 

 

 
 

From here, mapping mode can be toggled on or off. You must click ‘Save settings’ before 
the ECU will switch between modes. When in mapping mode (interpolation turned off), the 

status bar in the tuning software will display ‘Map mode on’. Once you have finished 
mapping the ECU, remember to disable mapping mode to reclaim the benefits of 
interpolation. 

 

Static timing / ECU status LED 
 

The most important setting in the Canems ECU is the static timing figure. This value 
(measured in degrees of crankshaft rotation) allows the ECU to recognise top-dead-centre 
on number one cylinder, and therefore deduce the positions of other cylinders in the 
engine. For more information about setting the static timing, see the section entitled 
‘Speed sensing’. 

 

The front panel on all Canems ECUs is fitted with a twin-colour status LED. This can be 
useful for a variety of diagnostic tasks. When power is applied to the ECU, the LED should 
turn red. This indicates that the ECU has a voltage supply and it is simply waiting for a 
crank sensor signal. When the engine is turned over on the starter-motor, the LED should 

turn green. A green light indicates that the ECU has detected a crank sensor signal and 
has successfully located the missing tooth of the trigger wheel.  

 

It is expected that the LED may oscillate occasionally between red and green whilst 

cranking, but it is important that this is not the case once the engine is running. A status 
LED which flickers to red indicates that the ECU has lost the position of the missing tooth 
on the trigger wheel, and it is therefore unable to perform fueling or ignition satisfactorily. 
A flickering status LED can indicate a defective crank sensor arrangement, electrical 
interference or poor earthing to the ECU itself.     
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